Garmin 1000 and Cycliq camera issues

KStwenty1

Active Member
#1
I just got the Cycliq front and rear bike cams/lights and today was my first commute. On my handlebar I also use a Garmin 1000 which was having a bit of trouble today holding it's satellite connection. the Garmin kept cutting on and off.

My question is:
Does anyone run the same devices and have had problems like this? Soluton?
 

szymon

Active Member
#2
I also have the cycliq front and rear cam/lights but use a garmin 810 or 520, never had any problems with connection.
 

Patrick

aka Fidodie
Staff member
#3
i think there were some recent firmware updates - make a quick check to see if you have the latest.

how are the cameras? you playing/reviewing the video, or just have it for an incident?
 

szymon

Active Member
#4
i think there were some recent firmware updates - make a quick check to see if you have the latest.

how are the cameras? you playing/reviewing the video, or just have it for an incident?
I use them more for if something were to happen, after too many close calls and only getting worse I don't ride without at least the rear one anymore. Mainly I want the video to be clear enough to see car plates and the battery to last longer then 3-4hrs at times and they do both. Really cant say anything bad about them, they just work.
 

KStwenty1

Active Member
#5
i think there were some recent firmware updates - make a quick check to see if you have the latest.

how are the cameras? you playing/reviewing the video, or just have it for an incident?
They are unbelievably stable and yes I just run them for....god forbid...an incident
 

KStwenty1

Active Member
#6
I use them more for if something were to happen, after too many close calls and only getting worse I don't ride without at least the rear one anymore. Mainly I want the video to be clear enough to see car plates and the battery to last longer then 3-4hrs at times and they do both. Really cant say anything bad about them, they just work.
Yes but that doesn’t address the issue I have with my Garmin 1000
 

szymon

Active Member
#7
Yes but that doesn’t address the issue I have with my Garmin 1000
Not sure why your garmin is causes the issue, the only time I've had a problem with mine was when my memory card was bad but I swapped it with another I had and it was fine. Are you using the right memory card, on another forum I know there have been some issues when people put in bigger cards then supported by the camera?
 

KStwenty1

Active Member
#8
I seem to have found a quick fix. I keep the Garmin in my shirt and all is well....except I can’t view the screen unless I take it out.